
A Freeway introduction

Freeway is desktop publishing for the web. A single Freeway document can contain all the pages you need in 
your site, and you lay out your work in a normal DTP-like way. Draw boxes, import images, set text... then 
publish, and Freeway looks at your layouts and works out the best way to recreate them using HTML and web 
graphics. Each time you publish (or just preview) your page design is reassessed from scratch and the web page 
code (the HTML and CSS) is rewritten from scratch. This means that you always have optimised code, but with 
no need to actually touch or even think about code to do it.

Getting Started

Launch Freeway and click the Templates tab in the New 
Document window. (Choose File > New if this window 
doesn’t open automatically.) Pick the Blank template 
and click OK. Now name your new site and choose 
where to save it.

What you have now is a new Freeway site document, 
with one page already set up. One the left side of the 
window is the Site panel, which shows the pages and 
folders in your site, and a toolbar runs along the top.

Of the buttons in this tool bar, the most important - for general work at least - are the Selection tool (the arrow, 
used to select and manipulate objects on the page) and the CSS button (toggles how items are made, more on 
this later), and the HTML and Graphic buttons, both of which are used to create boxes in the page layout.

At the right-hand end of the tool bar the 
Inspector button opens and closes the 
Inspector palette, the command centre of 
your Freeway life. Pressing and holding 
this button also shows a few other items, 
most important of which is Styles & 
Colors. This is where you manage and 
select text styles and colours as you work.

Out in the Finder, Freeway has created a 
complete folder structure for your new 
site, as long as you followed instructions 
and created your document from the 
blank template. Inside this new folder 
there is (1) the Freeway document itself, 
(2) a “Site folder” folder, where Freeway 
will put the HTML files it makes, and (3) a 
“Media” folder. 

The Site folder should normally be left alone. Freeway manages the contents of this folder completely, so the 
best thing to do is ignore it. The Media folder, on the other hand, is just there to encourage you to be tidy; it 
doesn’t have any magic powers. Put your original graphics and rich media files in there to help you keep track of 
things.

Back in Freeway, the top section of the Site panel contains a ‘master page’, something that every page you make 
is based on. Click on this icon to see the master page. Anything done here will be done to all the regular pages 
that use this master page.

Add a new page using the Page menu or by dragging a master page down into the main section of the Site 
panel. Give it a name, click OK, and you’re done, ready to build your new page layout.

Click page icons in this panel to see and work on different pages in your site. Add a folder from the Page menu 
or the popup menu in the cog icon at the bottom of the Site panel, and drag pages in and out of your new 
folder.

Stop! Download the samples at 

www.thehelpfu
l.com/files.z
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Page Layout

Like all DTP software, you draw out boxes on the page to hold your images and your text. There are two 
different kinds of containers in Freeway: HTML and Graphic. Think of HTML boxes as the equivalent of InDesign’s 
text boxes, and the graphic boxes as the rough equivalent of InDesign’s image boxes. Put your text in HTML 
boxes and your pictures in graphic boxes.

However, you can use graphic boxes for more than just picture holders... they can also be used for ‘graphic text’. 
Draw out one of these boxes, click into it, and start typing. Select your text and use the controls in the Inspector 
palette to format it.

What is graphic text? Well, Freeway turns type within graphic boxes into bitmap graphics when you publish your 
work, so it will always look precisely the way you set it. Graphic text lets you use whatever typeface you like and 
work with great typographic control, but don’t get carried away with it.

What’s wrong with graphic text? Simple: it isn’t REALLY text, it is just a bitmap graphic that looks like text. 
Search engines can’t read it, it looks fuzzy when printed, and it is thoroughly inaccessible to visitors with vision 
problems. Graphic text is useful from a design control point of view, but it is best to use HTML text wherever 
possible, despite its limitations.

So what are the limitations of HTML text? HTML text in a web page is plain text wrapped with instructions to the 
web browser telling it what font you’d like it to use. Because the final result is just a request for a visitor’s web 
browser to try to show some text using a particular typeface, you are relying on that font being available on their 
computer. There are not very many typefaces that you can rely on being ‘web-safe’ (being on virtually everyone’s 
Mac or PC), so you have a limited set of choices. Of these, the best are Verdana (a sans serif) and Georgia (a 
serif), with Trebuchet (another sans) as a fair alternative. Other web-safe fonts are Helvetica, Arial and Times, but 
these don’t look terribly clean or well-formed when set at body text sizes on screens.

Graphic image formats

Graphics in web pages must be in the right web-safe format: JPEG, GIF or PNG. Any other formats can’t be read 
(except by Safari, which likes to show off) and shouldn’t be used in web pages. HOWEVER - remember that 
Freeway’s job is to sort things out for you, turning your layouts into whatever it takes to make it work in a web 
browser. One of the things it does is optimise your graphics for you, so you can import whatever graphics you 
like and leave the dull web-optimising work to Freeway. In fact, it is best NOT to turn your images into JPEGs 
first, because Freeway will normally regenerate them anyway - applying a fresh round of lossy compression.

What kind of images can I use in my Freeway layouts? Pretty much anything you are likely to use on your Mac. 
Some of the best to use are native Photoshop (.psd), TIFF, PDF, and native Illustrator files. If you use files that 
include transparency, this will be carried through in your layout. Freeway will automatically set these to be 
generated as JPEG or GIF when you publish your work.

Remember the traditional rule of thumb: JPEGs are great for photographic-style content, GIFs are great for 
simple graphics with flat colours and sharp edges - for example, logos or graphic text.

How can I control what format a graphic will be? Use Freeway’s Inspector palette window. With any graphic box 
selected, the third icon will be the Item Output Settings; this is where you can pick what type of graphic will be 
made and select compression details.

How can I tell how much compression to use? Freeway defaults to 75% JPEG quality or 256 colours for GIF, and 
this works reasonably well for most circumstances. If you want to improve the quality or reduce the file size then 
adjust the Quality (for JPEGs) or Colors (for GIFs) slider in the Inspector palette. To see what effect this will have, 
turn on Freeway’s Graphic Preview feature - select View > Graphics Preview - and your graphics will be rendered 
and shown in their final form on the fly. This is very useful for making JPEG compression setting and GIF colour 
count judgements right there in your layout, but it can slow things down slightly so it is generally best not to 
work with this enabled the whole time.

But what about PNG? The third web-safe graphic format is PNG (pronounced “ping”), and this can work as 
either a flat-colour alternative to GIF or as a full-colour alternative to JPEG. It generally doesn’t achieve quite as 
small file sizes, but it has one key advantage that you might find useful on occasion: when the colour is set to 
‘Millions’ in Freeway it is created with an 8-bit alpha channel. This gives it the ability to have variable 
transparency, not just the ‘on/off’ cutout-style transparency of the GIF format. Use this to preserve the true see-
through appearance of soft shadows and any translucent areas of imported graphics.



Table or CSS Layout

Web page layouts are built using two different methods: table structures or CSS positioning. A table-based 
layout is like a two-dimensional scaffolding structure that holds item in place in the browser window. CSS-
positioned items, on the other hand, are independent little tykes that don’t need extra structures to help them 
work.

In traditional web production software you have to do at least some of the structural building work to make 
things sit where you want in the page. But in Freeway, this is all done for you; an invisible table structure is 
created to hold table-based things in place, and CSS-positioning code is whipped up to tell other items where to 
sit. All you have to do is choose whether a box you put on the page is to be layered (i.e. CSS-positioned) or not 
(i.e. table-managed) - and you can change your mind at any time without any fuss.

To make things you are GOING to add to the page be table or CSS-positioned, click the CSS button in the 
toolbar. It toggles between CSS Layout (blue) and Table Layout (grey). To make something that is ALREADY on 
the page behave as table or CSS, select it and use the Layer checkbox in the Inspector pallete; layered is CSS, 
unlayered is table-based.

Okay, so what should I use, table or CSS stuff? It is generally better to use CSS (layered) layouts, although you 
really shouldn’t get too concerned about it, just understand the subtle differences in how things work. Leave 
that button set to CSS Layout and make your layout as normal.

If you work with the CSS button turned off (grey) then unlayered, overlapping graphics will be merged in the 
output and be shown as a single graphic in the browser. If you work with the CSS button turned on (blue) then 
overlapping graphics will each be output separately, layered, and stacked as required in the final output.

If you want to change an item from being unlayered to being layered just check the Layer checkbox in the 
Inspector palette. Uncheck to turn a layered item into an unlayered one, of course.

If you want two graphics to be merged but you don’t want to make them unlayered, select them both and 
group them together by choosing Item > Group. This wrapes them up in a new container object, and that item 
can be made to be layered. Rollover graphics must either be unlayered or grouped together, preferably before 
applying the Rollover action.

But how do I make rollovers? That’s pretty simple, although there are a few 
things to remember. First, a standard rollover is achieved in a browser by a bit 
of JavaScript that swaps one image for another when something (i.e. your 
mouse moving across) triggers it. To get this done you need to set up both 
the normal graphic and the one that gets shown when your mouse is over it.

If you’re working with unlayered graphics just put one on top of the other, 
then (with it still selected) choose Item > Actions > Rollover. In the Actions 
palette (can’t see it? choose Window > Actions), make sure you’re looking at 
the Images panel, then simply click the checkboxes on and off to set up 
which combination of graphics you want visible in the Normal and the 
MouseOver states.

If you’re working with layered graphics then you must group the items together first, or the Rollover ‘action’ 
won’t be able to see the separate layered items. Once grouped, apply the Rollover action and proceed as above.

Links

Web browsing is all about links between pages. To 
make something a link to a page in your Freeway 
document, select it, click the ‘link’ popup menu item at 
the bottom of the document window, and choose 
which page to link to. What you select can be a graphic 
object or some text. However, you can’t use an HTML 
box itself as a link, only some selected text within it.

Alternative methods are dragging a page icon from the 
Site panel down to this Link popup menu, and going to Edit > Edit Hyperlink. This last option provides a wide 
range of options, including links to external sites. Remember to include the full path including http:// for all 
external links.



Rich media and dynamic effects

Adding rich media such as Flash or QuickTime is ridiculously easy: just drag and drop it into your page. Like 
everything else, Freeway will upload the media for you when you publish and upload your work. (Although if 
your rich media uses external files, for example a Flash slideshow with external images, then Freeway won’t 
know about those other items and won’t upload them for you.)

There’s a YouTube ‘action’ for embedding a YouTube video in your page, and other actions allow layered (CSS) 
objects to be hidden or shown, with transition effects if you like, and even moved around the page. See Actions 
for details.

QuickTime movies can have the controller visible or hidden, be autoplay or not, and loop or play once (or play 
back and forth). To scale the movie to fit your box and to set the playback volume you’ll need to apply the 
QuickTime Extras action; select the movie in the page and choose Item > Actions > QuickTime Extras, then look 
in the Actions palette window.

Flash (SWF) movies can have embedded links managed by Freeway so that they are rewritten to point at any of 
your document’s pages; this means a Flash navigation system can be integrated easily and won’t need to be 
rewritten if you change your site structure around.

Backgrounds

Background images are not just pictures that are sent behind other objects - they are graphics that are set as the 
background of the page itself. Think of it being like having pre-printed stationery.

With nothing selected, click the second icon in the Inspector palette and use the Image popup menu to select a 
ready-made web-format, web-optimised graphic; GIF, JPEG or PNG. (Alternatively, hold down the Shift key while 
you drang-and-drop the graphic into your page.) Then control the horizontal and vertical image tiling with the 
menus that appear.

Image tiling? What’s that? When you put an image in as a page background it will automatically be repeated 
both horizontally and vertically as necessary to fill up the page - and the browser window when you preview it. If 
you prefer you can set it to be pinned to the top, middle or bottom and left of the window instead, and pin it to 
the left, centre or right horizontally.

Try making a web-ready graphic that’s, say, 30 pixels tall by 2000 pixels wide. Fill it with a solid colour and fill a 
600 pixel-wide section in the middle with a different colour. Apply this as a page background, set it to be 
centred horizontally and tile vertically, then arrange your layout within the middle section and set the page to be 
aligned to the centre as well. This will give the effect of a ‘page within a page’.

Actions

What are those actions things you keep mentioning? Actions are Freeway’s equivalent of InDesign plugins or 
QuarkXPress Xtensions. These add features in various ways, from rollovers and simple animation effects to 
sophisticated in-page image adjustments, Google map embedding, easy Flash FLV video support, Lightbox image 
display, integration with external content management systems, and more. Most actions are applied to objects 
(select something and look in Item > Actions) or pages (look in Page > Page Actions), but you can also add these 
as complete separate items in the layout (look in Item > Actions).

Action parameters are configured in the Actions palette, found in the Window menu. Freeway comes with a 
core selection of useful actions, but there are many more that are written by Softpress engineers and Freeway 
users. These are available from the Softpress site, the actionsforge.com site, FreewayActions.com, 
ActionsWorld.com and a number of others. These allow Freeway designs to be extended in all sorts of directions, 
and the vast majority of them are free.



Previewing, publishing and uploading

Freeway layouts are not HTML. This is an important point to remember. Like InDesign and QuarkXPress layouts, 
they are built in a layout model that is far richer and more flexible than the final output media can achieve - and 
this is what makes it a good design tool. Make a layout, and when you preview it Freeway generates the code 
required to recreate your design in HTML form. Go back and adjust one thing on that page and preview again, 
and Freeway throws out all the code it just made and generates new, optimised output from scratch.

Uploading is normally best done from within Freeway rather than with a separate FTP client application. This lets 
Freeway handle keeping the contents of your web server current; as well as uploading new content, it will 
remove pages and files that are no longer in use, things you’ve deleted from your Freeway document. This meas 
you can focus on managing your site from the single Freeway document, using the Site panel on the left of the 
window, and leave the grunt work to the software.

So what’s the difference between previewing, publishing and uploading? These are all related things, but they 
do have different roles. Most of the time, as you work, you’ll use the Preview options to see how things work 
both in terms of precise rendering in a browser and in terms of the interactivity of rollovers, links, menus and so 
on.

• When you use Freeway’s built-in preview feature, just the page you’re working on is generated and you’re 
shown that within Freeway.

• When you preview in a browser all the altered pages in the entire site are rebuilt, and the page you’re on in 
Freeway is shown to you in a browser.

• When you publish, all your altered pages are regenerated, but nothing is shown to you in a browser.

• When you use Freeway’s Upload feature, your site is published (see above) and then Freeway handles 
uploading new content and clearing out the old files.

Oh, and those ‘browser hack’ things that web programmers research, fine-tune and put into their pages to get 
different things to work properly in rogue browsers such as Internet Explorer? They’re included automatically as 
required, even the ‘PNG Fix’ that forces sophisticated transparency to render properly in Microsoft’s poor excuse 
for a web browser. Life is good, so get on with designing.


